commit 7f8786babde6ccfff0a5ba3d24072e2edc6a984b
Author: Bryan Joshua Pedini <bryan@pedini.dev>
Date:   Tue Sep 17 08:58:16 2024 +0200

    added pman helper build scripts

diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 0000000..2c1c6fd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = pman-helper
+	pkgdesc = A pacman helper script, because you forget all the stupid flags
+	pkgver = 1.1.1
+	pkgrel = 1
+	url = https://git.bjphoster.com/source/pman
+	arch = any
+	license = MIT
+	depends = bash
+	depends = pacman
+	conflicts = pman
+	source = https://git.bjphoster.com/source/pman/archive/1.1.1.tar.gz
+	md5sums = 04826025b56e9ab28f79f63cbb5b0f60
+	sha1sums = 908e8746681f3b0f65128a05bf954f24e0d57346
+	sha256sums = ab090fa3c7e4e5c97725799e27106ccb5506b05e0f0d43c0688f26371376c771
+
+pkgname = pman-helper
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..deccadf
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+# downloaded tarbals
+*.tar.gz
+# built packages
+*.pkg.tar.zst
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 0000000..e858eff
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2024 Bryan Joshua Pedini
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 0000000..50e77e8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Bryan Joshua Pedini <bryan [at] pedini [dot] dev>
+
+_pkgname="pman"
+pkgname="$_pkgname-helper"
+pkgver="1.1.1"
+pkgrel="1"
+pkgdesc="A pacman helper script, because you forget all the stupid flags"
+url="https://git.bjphoster.com/source/${_pkgname}"
+arch=("any")
+license=("MIT")
+depends=("bash" "pacman")
+conflicts=("pman") # Another package called `pman` currently exists in the AUR
+source=(
+    "https://git.bjphoster.com/source/${_pkgname}/archive/${pkgver}.tar.gz"
+)
+sha1sums=(
+    "908e8746681f3b0f65128a05bf954f24e0d57346"
+)
+sha256sums=(
+    "ab090fa3c7e4e5c97725799e27106ccb5506b05e0f0d43c0688f26371376c771"
+)
+md5sums=(
+    "04826025b56e9ab28f79f63cbb5b0f60"
+)
+package() {
+    mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}"
+    mkdir -p "${pkgdir}/usr/bin"
+    install -Dm644 "${srcdir}/${_pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+    install -Dm755 "${srcdir}/${_pkgname}/pman.sh" "${pkgdir}/usr/bin/${_pkgname}"
+}
diff --git a/README.md b/README.md
new file mode 100644
index 0000000..26a4c69
--- /dev/null
+++ b/README.md
@@ -0,0 +1,2 @@
+# pman-helper
+PKGBUILD script for arch linux for `pman-helper` package (`pman` command)